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Introduction

The Marc 2020 release contains new and enhanced solver and GUI capabilities for both specific work flows and general-

purpose applications. In particular, this release includes enhancements to work flows involving induction heating and creep,
while also delivering improvements to efficiency, performance, ease-of-use, robustness and accuracy across the majority of
general-purpose work flows. Marc 2020 is the first Marc release supporting fatigue analyses for elastomeric materials.

m The Marc 2020 release also contains defect corrections associated with previous releases.

® Marc 2020 uses a different compiler version as Marc 2019 Feature Pack 1. See List of Build and Supported Platforms -
Marc 2020 Release for more details.

® Marc 2020 requires the “Helium” release of MSC Licensing which uses FLEXIm 11.16.3.0. Please refer to the
Marc and Mentat: Installation and Operations Guide for more details.

Overview of New Functionality
The new functionality in Marc 2020 includes:
® New and Expanded Work Flows
e Significant improvement to creep simulations by enabling Material Data Fitting of creep data.
 Expanded definition of E-M induction coils to include arbitrary shapes.
* Improved convergence of thick walled coils.
* Marc Co-Sim Adapter Compatibility with version 2020.
* Fatigue analysis for elastomers.
= Smarter Solve
* Interactive Analysis Statistics Report improves the model verification and debugging process.
* Improvements to contact robustness and efficiency.
e GPU Support for matrix operations to improve the performance of the iterative solver (Solver 2).
® Smarter Simulation Environment
* Improvements to the process of creating and modifying Mentat Tables.

* Ease of use improvements for model set up in Mentat by the introduction of the Model Dimension, which can
be 3-D, axi-symmetric or planar. This allows for a consistent DOF identification in planar and 3-D models, and
depending on the Model Dimension, display of only the relevant model options and parameters in various
menus.

 The default structural formulation has been changed to the nonlinear large strain formulation.

* More intuitive default naming of copied entities.

* Ease of use improvement for selecting plotted increment.

* Improved performance of results monitoring during post processing.

* Flexibility in defining quad sheet bodies and more accurate and easy to control rendering of solid bodies

More details can be found in the User's Guide in the chapter called What's New, along with examples to guide the user in
applying the new functionality.
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List of Known Defects in the 2020 Release

Marc

Contact

MARC-7984 When using node-to-segment contact in a coupled Thermal/Structural analysis, if a node contacts both a
surface with glued contact and a surface with touching contact, then there is incorrect heat transfer on the
touching face.

MARC-13581 A beam-to-beam contact analysis using the node-to-segment algorithm may fail if nodal transformations
are used.

MARC-12637 Selecting the Near Contact Distance post code may significantly increase the stress recovery time.

Global Remeshing

MARC-7978 Hard nodes in the interior of the mesh are not available when using Global Adaptive Meshing in 2-D,
hence if a boundary condition such as a Point Load, Fixed Displacement is applied to a point, then after
remeshing, it will be applied to the node of the new mesh with the same ID as the node from the original
mesh that is attached to the point, but this node may be in a different location.

Multi-Physics

MARC-12101 The options INITIAL STATE and POINT TEMP cannot be used in the same analysis, even if INITIAL
STATE is not referring to the first state variable (temperate).

MARC-13682 Though thick-wire coils are only supported in magnetodynamic analyses, neither Marc nor Mentat issues
any warning or error message if they are used in a magnetostic analysis.

Parallel Processing

MARC-12227 In rare cases, a Node-to-Segment DDM contact analysis using the RBE2 option may stop prematurely
with exit number 1004.

MARC-8690 If a Marc model uses non-consecutive node and element numbering such that the ID’s are much larger
than the number of nodes and elements in the model, then the amount of memory required in a DDM
analysis is significantly larger than in a serial analysis.

User Subroutines

MARC-10057 In a segment-to-segment contact analysis, the nodal post code Contact Stress is not supported by user
subroutine NODVAR.F
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Loads, Boundary and Initial Conditions

MARC-12897
MARC-12870

MARC-12643

Other
MARC-11485

MARC-12171

Mentat

General
MARC-11742

MARC-8600

MARC-5408

MARC-5343

MARC-14414

MARC-13491

Preprocessing

MARC-10183
MARC-6598

MARC-6492

The TYING CHANGE option may not work correctly with the RBE2 option.

If elements are deactivaded during the former job, the Prestate option may fail with a misleading error
message.

In a restart analysis, if remeshing does not occur, the SURFACE SECTION option may not be correctly
written into a Model Section file.

In rare cases, if the dynamic allocation of memory fails, Marc will stop prematurely without printing a
clear error message.

The nodal post code External Pressure is not correct for 10-node tetrahedral elements. This does not affect
any other analysis results.

In very rare cases, the option to plot surfaces in the mode "Solid Display Without Lines" causes Mentat
to crash.

The database function set_entry(), that returns the id of a specific entry of a set, does not function for sets
of type solid, solid_face, solid_edge and solid_vertex.

The cross hairs option, which was available in Mentat Classic to provide guidance when picking items
from the graphics window and which could be activated by clicking the SHIFT key on the graphics
window, is not supported in the new Mentat.

Faceted surfaces can not be duplicated, neither using the commands in the Geometry & Mesh > Duplicate
menu, nor using the commands in the Geometry & Mesh > Symmetry menu.

If multiple tables are present in a model, if you modify any of the existing table parameters followed by
the Undo option, the first table in the list of tables will become the current table.

In Contact Table Property menu, for some rare combinations of contact bodies, Make visible option may
not work as expected and may continue to display all the contact bodies on the canvass.

In Mentat, the internal pressure on element type 31 (pipe element) cannot be defined.

In 2-D models, Mentat allows one to apply initial conditions like Initial Temperature, Initial Velocity, etc.
on surfaces. However, this is not supported by Marc. Such initial conditions must instead be applied to
the nodes of the faces attached to the surfaces.

No Planar Truss Geometric Property type is available in Mentat to define the properties of Marc element
type 9 (a truss element which can be used both in 2-D and in 3-D analyses) if the element is used in a 2-
D analysis. As a workaround, a Geometric Property of type 3-D Truss can be created instead.
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MARC-5352

MARC-4596
MARC-4544

MARC-3587
MARC-3511
MARC-2136
MARC-1622

MARC-13717
MARC-13465

Postprocessing

MARC-10509

MARC-10225
MARC-10126

MARC-8764

MARC-8114

MARC-5906

List of Known Defects in the 2020 Release

Mentat does not support Geometric Properties for Electrostatic analyses to define for example, the
thickness of a shell. The workaround is to temporarily change the Analysis class to Thermal, create a
Thermal Geometric Property of the appropriate type for these elements and then change the Analysis Class
back to Electrostatic.

Mentat allows creating materials with identical names. This can be confusing when selecting a material.

Mentat does not support the Marc option to choose magnitude/phase or real/imaginary nodal output in
harmonics for the PRINT NODE option.

Multiple axes of rotation for Centrifugal loads are not supported within Mentat.
The General Traction distributed load type 21 is not supported within Mentat.
Mentat does not support the Foundation option for 2-node line elements.

Mentat is unable to control the prescribed displacement boundary conditions in a Modal Dynamics Load
case. This may results in problems with Design Optimization in a modal dynamics simulation.

If a meshed solid is scaled, then boundary conditions applied to the solid are lost.

Mentat records the dynamic viewing command with the view number, but doesn't record the graphics
window (such as Model, Table, Path Plot,etc.). So, in some cases the wrong graphics window may be used
when executing the procedure file.

If sample point data is tracked using the post file of a pure thermal analysis involving remeshing, then the
option Fixed Points In Space must be set. If this is not done, no warning message is given and an incorrect
sample point plot may be created.

Data collection for History Plotting does not function correctly if sub-incremental data has to be collected.

Model clipping by results scalar does not work when the nodal averaging of the results is turned off. Only
exterior faces of the visible elements are shown and internal elements do not show up at all.

If a report is created using the Report Writer for selected entities (nodes and/or elements) and over a list
of increments while post-processing a job with adaptive meshing, then no data will be reported for the
selected entities, unless they have been selected in the finite element mesh of the first increment in the list.
In that case, data will also be reported for subsequent increments in the list until the finite element mesh
changes. A workaround is to create a report of the current increment for the selected entities, or for all
entities over the increment list.

If the entities (surfaces, curves and points) of a trimmed geometric contact body are made invisible through
the command sequence Select Contact Body Entities / Make Invisible, then the trimming curves show up
again when skipping to an increment with a different mesh (due to remeshing). Workaround is to make
the contact body itself invisible, e.g. through the Model Navigator.

If Cutting Planes are defined in postprocessing and the extreme values of the quantity are assumed on the
cutting plane and not on the surface of the model, then these extreme values are not reflected in the legend.
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MARC-5748

MARC-5015

MARC-4622
MARC-1226

Marc Writer
MARC-9714

MARC-8105

MARC-7996

MARC-7215

MARC-5929

MARC-4047

MARC-13681

MARC-12459

When postprocessing jobs in which VCCT cracks are initiated during the analysis (i.e. not all cracks already
exist at the start of the analysis), then history plots involving crack related quantities, such as Energy
Release Rate, Accumulated Crack Growth and the Number of Fatigue Cycles, may be incorrect if the data
is collected in a range of increments in which a new crack has been initiated. The workaround is to collect
data from the increment in which the crack has been initiated to the last increment before the next crack
is initiated.

The automatically computed range of the current scalar or vector quantity, as shown in the Scalar Plot
Settings and Vector Plot Settings menus, respectively, is not updated automatically if one skips to a different
increment. The legend on the graphics window shows the correct range though. The menus can be
updated by pressing the Enter key once in the “Command” box of the Dialog, i.e. by entering an empty
command string.

In rare cases, a non-symmetric contour plot is shown for a symmetric problem.

The automatically computed value range for a vector plot of 3-D continuum elements may be wrong when
only the Edges on the Surface are being drawn.

If a Marc input file is created for a segment-to-segment contact analysis with a non-zero interference
closure, but without augmentation, Mentat will not issue an error message, although the Marc analysis will
stop with exit number 13.

If old-style input is used, an incorrect input file may be written for a job that contains a harmonic load
case with a distributed load. Workaround is to use new-style (table-driven) input.

If a model has multiple radiation cavities, each cavity should have its own boundary condition, instead of
assigning the same boundary condition to multiple cavities. However, Mentat will not issue a warning or
an error message in such cases.

User defined point, curve and surface sets consisting of points, curves and surfaces of a geometric contact
body, or of points, curves and surfaces which are not used in the finite element analysis (i.e. do not have
mesh attached, are not used to define the material coordinate system of an Orientation, etc) can be written
to the Marc input file as empty sets and thus will show up in postprocessing also as empty sets for DDM
analyses using decomposition in Mentat.

If a WELD FLUX boundary condition is not explicitly selected in a load case of a restart analysis, Mentat
does not write WELD PATH and WELD FLUX data into the Marc input file, causing Marc to stop
prematurely with exit number 77.

Mentat does not write a correct Marc input file if two node, element, edge, face, point, curve, or surface
sets exist with the same name.

When defining a centrifugal load in a model that consist only of axisymmetric model sections (without
any element in the model), the definition of the axis of rotation is not written to the *.dat file.

Standard beam sections such as Rectangular, Circular, Elliptical, Square, Triangular, etc. are not written
into a Model Section file (as opposed to customised beam sections using Area, Ixx and lyy).
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Marc Reader
MARC-9765

CAD

MARC-8660
MARC-8002

MARC-5655

MARC-14461

Other

MARC-9925
MARC-7266

List of Known Defects in the 2020 Release

The OP2 option is not supported.

On rare occasions, defeaturing may not work correctly for certain features, like chamfers, fillets, etc.

The Holes and Pockets options in the Import = General CAD As Solids = Defeature Settings menu, that allow
one to select the types of holes that are to be removed when importing a CAD model, do not work. If the
Remove Holes/Pockets option is switched on, then all holes and pockets with a radius within the given
range are removed from the model.

For some CAD models, the automatic feature removal options in the File > Import > General CAD As Solid
menu may fail. Workaround is to remove the features after import via the Defeature menu on the Geometry
& Mesh tab of the main menu.

For intricate geometries, switching off the Auto Calculate Tolerance option in the Solid Plot Setting menu
may cause the geometry to be displayed incorrectly.

The Marc Movie program fails to import multiple RGB files at once.

When using remote access (for example, VINC) to use Mentat on a Linux machine, creation of GIF movies
may fail; the image may appear mirrored.
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List of Fixed Defects in the 2020 Release

Marc

Multi-Physics
MARC-14951

MARC-14542
MARC-14492

MARC-14435

MARC-14394

MARC-14368
MARC-14347

MARC-13909
MARC-13654

MARC-13645

MARC-13607

MARC-13572

MARC-13969

MARC-13969

The results of a curing analysis using one or more of the element types 127, 130, 136, 155, 156, 157, 184,
239, 240 and 241 were incorrect.

In a magnetodynamic pass a table could not be used for a coil current boundary condition when this
boundary condition is applied to a thick wire coil.

If in a coupled magnetostatic/structural analysis Lorentz forces are computed, It could happen that a coil
current boundary condition was deactivated after remeshing.

Table input style was not complete supported for piezoelectric materials: the relative permittivity and the
inverse relative/absolute permittivity were not supported; moreover, the electrical permittivity could not
depend on a table.

The evaluation of tables involved in the film molar flow rate (such as for the sink concentration or the
transfer film coefficient) has been improved for cases where the molar concentration is used as an
independent variable (by taking into account the estimated value of the molar concentration).

The Load Case Solution Control options Non-Positive Definite and Assembly Each Iteration were not
taken into account for Multi-Physics style input, except if a structural analysis is performed.

The computation of the total current density in axi-symmetric thick wire coils was less accurate at higher
frequencies.

The computed reaction charges were incorrect for harmonic magnetodynamic analyses.

In a coupled analysis including a thermal pass, if a film load is defined for the other pass (e.g. MOL FILM
for molecular diffusion) by a table depending on the temperature, then the temperature used for the table
evaluation was incorrect.

When in a magnetodynamic analysis a distributed current is applied using user subroutine FORCEM, the
post quantities "Real (or Imaginary) Applied Current Density" and "Real (or Imaginary) Current Density"

were incorrect.

When in a harmonic magnetodynamic analysis pass thick wire coils are used and the coils are partdy
modeled using anti-symmetry or cyclic symmetry, in some cases the length of the coil could be computed
incorrectly. This would result in a wrong applied current.

When in a coupled magnetostatic/structural analysis a permanent magnet is defined using orthotropic
material properties with a shifted B(H) relation, the computed Lorentz force was incorrect when the
virtual work finite difference method is used.

If subroutine FLUX is used for molecular diffusion (flagged on the DIST MOL model definition option),
the concentration passed as an input quantity to FLUX was zero.

If subroutine FLUX is used for molecular diffusion (flagged on the DIST MOL model definition option),
the concentration passed as an input quantity to FLUX was zero.
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Contact
MARC-13966
MARC-13908

MARC-13896

MARC-13880

MARC-13790

MARC-13711

MARC-13707

MARC-13631

MARC-13558

MARC-13455

Restart
MARC-14805

MARC-13895

MARC-13612

List of Fixed Defects in the 2020 Release

Augmentation for Segment-to-Segment contact could not be deactivated in a restart analysis.

Penalty factor print-out in the output file only reflected changes made to the scale factor in the global
CONTACT CONTROL menu (CONTACT card) and did not reflect changes made to the scale factor
in the CONTACT INTERACTION menu (CON INTERA card). Note that the analysis itself used the
updated penalty factor and the problem was only with the print-out.

Load controlled meshed rigid bodies with transformations on the control node could produce incorrect
results.

In a domain decomposition analysis, the values of the film heat flux and the film molar flow rate on the
post file could be incorrect. This did not affect any of the other analysis results.

If a node touches multiple segments of the same contact body, the Near Contact Distance (nodal post code
65) was reported as a negative number.

For segment-to-segment contact, shells that were continuous but in two separate contact bodies, could be
erroneously detected as being in contact along the common edge. Such common edges are now skipped
in the contact check.

In rare cases, if in a transient dynamic analysis with adaptive time stepping a load-controlled rigid body is
not sufficiently constrained by contact or boundary conditions and it undergoes very large displacements,
the time step could be reduced to a very small number, finally leading to a program crash. Protection

against the crash has been added, and a warning message is printed if such large displacements are detected.

In rare cases, if a Geometric Contact Body consists of segments having a small area (order of magnitude
le-12), then contact with this body could be missed completely (this happened both for the node-to-
segment and the segment-to-segment algorithm).

External heat fluxes reported in the output and on the post file were wrong in a segment-to-segment
contact analysis without friction. All other results were correct.

In 3-D remeshing analysis with the remeshed body in contact with shells where the thickness is not taken
into account and only top or bottom surface is used, then in certain cases nodes could incorrectly be moved
to the contacted shell body during re-meshing.

When in a global-local analysis in the global analysis a restart is performed and the data from the original
post file is not copied to the new post file, Marc could end prematurely.

When a restart of a job is done, where in the original job the model definition option NAMES is used,
but not in the restarted job, Marc could end prematurely. This could particularly happen if a long name
is used for a load case in the original job, but a regular name for a loadcase in the restarted job.

The scale factors for normal and tangential penalties for segment-to-segment contact could not be changed
in a restart run.
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Other
MARC-14802

MARC-14259

MARC-13573

MARC-13536

Local Adaptivity

MARC-14432

MARC-13795

When the option to print element volume, mass, and energy is chosen, the mass was not printed correctly
when the post quantity "principal values of total strain tensor" is requested.

"Stress and Strain output on the post file and access via ELMVAR had a number of inconsistencies for
layered elements:

(a) Generalized Stresses for layered beams (solid section beams / beams identified through thin-walled
sections) were incorrect. Now, the generalized stress tensor (post code 311 without a layer number which
refers to beam forces and moments) is available as described in Volume B for each beam element.

(b) Cauchy stress (and many other stress and strain quantities) are not available in generalized form - by
default, they are available at layer 1 for layered elements (shells, composite solids, solid shell, layered
beams). The terminology on the post file now refers to the Cauchy stress (and such quantities) as ""Cauchy
Stress at Layer 1"" so that it is very clear that the ""Cauchy stress"" is a true stress quantity as opposed to
the generalized stress (which is a force / moment quantity for layered shells and beams).

(c) Harmonic stresses were only available at layers with the default layer always being 1. Now, generalized
harmonic real and imaginary stresses for shells and layered beams are available when no layer number is
specified.

(d) Harmonic strains were available in generalized form (membrane strains and curvature strains) and in
layer form - however, on the post file, these quantities were inter-changed. i.e., when no layer number was
specified, the layer 1 strains were output. When a layer number was specified, the generalized strains were
output. This is now corrected for harmonic real and imaginary strain tensors and equivalent harmonic real
and imaginary strains."

In a model with radiation, the calculated values of the Film Heat Flux and Reaction Heat Flux were wrong
for nodes with radiation to the environment. All other results were correct.

When elements are deactivated in a load case via the DEACTIVATE option, the Glue Deactivation Status
and the Contact Status were lost.

A thermo-mechanical welding analysis could end prematurely with exit number 61 when the activated
weld filler is subdivided due to local adaptive meshing,.

In some cases, a segment-to-segment contact analysis with local adaptivity and solid shell elements (type
185), could yield NaN's in the contact stress output.
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Global Remeshing

MARC-14419

MARC-13824

MARC-13780

MARC-13651

MARC-13557

MARC-13474

MARC-13442

In 3-D tetrahedral remeshing with designated regions and Herrmann type elements, the displacements at
the interface between the part of the contact body being remeshed and the part which is not, were
incorrectly zeroed out. For large deformations, this would lead to incorrect results or the analysis could
even fail to run to completion.

With crack initiation using remeshing, distributed loads that are present where the crack is added should
be extended into the new crack faces. However, this was not done correctly when the loads are applied to
solid faces and there are multiple solid faces on which the load is applied. Also, other loads than distributed
loads applied on solid faces were incorrectly extended into the new crack faces.

In rare cases (typically with very small models with a relatively large number of boundary conditions), an

Tkskok

analysis involving global remeshing could stop prematurely, after having printed the message warning

- memory overwrite detected by marc_memsize!".

Remeshing combined with element deactivation could in some cases lead to a premature ending of the
analysis.

Symmetry and cyclic symmetry contact will no longer be considered in 3-D tetrahedral remeshing with
mesh density control based upon contact status.

3D remeshing could fail if the model dimensions are such that the element sizes are very small, like edge
lengths of 1e-6 or smaller. The new mesh after remeshing could become quite irregular in this case.

An analysis involving element type 28 (quadratic quadrilateral axi-symmetric element) would stop

prematurely with exit number 13. The workaround was to use the FEATURE,21001 parameter option.

When using the relax mesher for planar or axi-symmetric quadratic elements, the option to relax nodes in
contact could cause the analysis to stop prematurely with exit number 1005.

User Subroutines

MARC-14388

MARC-14205

MARC-14075

MARC-13912

When user subroutine plotv is called in a multiphysics analysis the vector "t", which contains the state
"non

variables, could contain wrong values. In a coupled Magnetodynamic/Thermal analysis, the vector "s" is
not defined, but could contain illegal values.

The utility subroutine UT_TRANSFORMTENSOR would produce wrong results for the case of non-

composite shells.

User subroutine UCOHESIVE did not have a separate array to define the change in stress due to the
change in temperature dependent properties (which might improve the convergence behavior).

The strains passed into user subroutines UFAIL and MD_UFAIL were not correct if varying thermal
strains are present in the model. Now the thermal and plastic strains are passed also into these user
subroutines.

1
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Parallel Processing

MARC-14312

MARC-14195

MARC-13941

MARC-13579
MARC-13266

The command line option "-gpu auto” and the utility program "deviceinfo" have been updated to
recognize all applicable GPU cards.

Number of CAD faces for a single solid in a solid:face set were limited to 99 in a parallel run using domain
decomposition. The allowed number is increased to 9999 now.

The single post file of a DDM analysis using the CROSS-SECTION option with the simple method input
mode, was corrupt and could not be opened by Mentat.

In rare cases, a single input file DDM analysis with post file revision 11 would stop prematurely.

In rare cases, a DDM analysis using local adaptivity could stop prematurely.

Loads, Boundary and Initial Conditions

MARC-14206

MARC-13753

MARC-13670

MARC-13652

MARC-13527

Materials
MARC-14050

MARC-13860

MARC-13854
MARC-13772

MARC-13671
MARC-13489

The option to exclude a film load if an element edge (2-D) or face (3-D) is fully in contact (by entering a
1 in the 6th field of the 3rd data block of the FILMS option for table-driven input) did not work. The

workaround was to enter a -1 instead of a 1 in the above mentioned input field.

Reading temperatures from a post file in a creep analysis using fixed time stepping with the CREEP
INCREMENT history definition option repeatedly read increment 1, but not the subsequent increments.
Now each CREEP INCREMENT reads a new increment from the post file.

When performing a Job Check, a warning message is generated now for cavities defined by surfaces only,
i.e. without elements attached to the surfaces.

Initial conditions applied using the PRE STATE option did not work correctly for the exponential cap
powder material model.

If the post file used by the PRE STATE option is based on a model with non-consecutive node numbering,
Marc issued a warning message in the output file, but nevertheless continued and performed an incorrect
mapping of the nodal temperature.

When phase transformation is modeled using a time-temperature transformation curve (TTT),
unexpected phase transformations could occur when the temperature is held exactly constant.

In a RP-FLOW analysis, the initial strain rate (defined on the PARAMETERS option) was not correctly
applied if a structure is loaded for the first time after increment 1 (e.g. if increment 1 is used as an
APPROACH load case). In such cases, instead of the initial strain rate, the cut-off value of the strain rate
was used as a first estimate of the strain rate.

Defining anisotropic plasticity via user subroutine UANISYLD did not produce correct results.

If element type 247 is used in an analysis with a Rigid Plastic material model, then in come cases the
analysis would converge slowly or not at all.

The Gurson damage model could produce NaN's if the hardening modulus of the material is equal to zero.

The reported value of the Yield Stress at Room Temperature for the Chaboche plasticity model was wrong,.
Note that this value is used only for post processing; it does not affect the result of the analysis.
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MARC-13326 Applying the Buyukozturk yield criterion to plane stress elements could cause the analysis to abort
prematurely.

MARC-7611 A new shift function has been added which combines the Williams-Landel-Ferry function and the
Arrhenius function. A capability has been added to define the shift factors directly with the help of a table.

Fracture Mechanics

MARC-13856 The output for the J-integral results was incorrect for the case that a crack is created with crack initiation
and there are multiple cracks. This applies both to the results written to the output file and to the post file.
If the J-integral is used for crack propagation, then the correct values would be used.
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Mentat

General
MARC-14926

MARC-14676

MARC-14670

MARC-14482

MARC-14355

MARC-14055
MARC-14054

MARC-13792

MARC-13684

MARC-13635

MARC-13594
MARC-13571

Mentat could terminate prematurely if the element labels are displayed for elements attached to solid, sheet
or wire bodies with very long names (more than approximately 75 characters) and the attach information
(i.e. the name of the body to which the element is attached) is included in the element label.

For bushing elements with the local X-direction defined by the beam axis and for 2-D beam elements, the
colors of the arrows used to indicate the local Y- and Z-directions of these elements were not correct. This
was primarily visible in the dark theme, where red, green and blue arrows are used to indicate the local X-
, Y- and Z-directions, respectively. For bushing elements and 2-D elements, however, the Y-direction was
indicated by a red arrow and Z-direction by a green arrow. The problem was not immediately visible in
the light theme, since the arrows are by default displayed in black, but could show up in that theme as well
if one would change colors of these arrows (by changing the Triad X, Triad Y and Triad Z colors in the
View>Graphics Colors menu). Note that, even though the colors were wrong, the arrows were correctly
labelled "Y" and "Z", respectively.

If the option Identify Sets is active and in the model navigator a set is disabled (usually by switching off
the check-box or via the RMB -> Hide option), then an incorrect color box was shown for this set.
Changing the color of that box would change the background color of the graphics area.

When using the dark theme, some icons in the model browser were almost invisible. In Marc Mentat 2020,
icons have been improved for Tables, Transformations, RBE2's, RBE3's, Cavities, Chains, Nodal Ties,
Servo Links, Welds, and Coils.

The performance of the Model Navigator has been improved for folders containing a huge number of
items.

The performance of writing the backup file for the UNDO/REDO operations has been improved.

Nodes associated with a Weld Path were considered as free nodes and got removed upon using the
command to delete all nodes.

If the Show Node command is used for a node which has a transformation and which is attached to a point,
Mentat could crash.

Starting Mentat in a directory that contains many files or sub-directories (several thousands) could take a
long time, in particular if the directory is located on a disk that is mounted from another machine (i.e. a
network drive on Window or an nfs-mounted disk on Linux).

If the mouse wheel is used to zoom in on the location under the mouse pointer and the Mouse Zoom
Method in the View>View Control menu is changed from the default Zoom Camera method to Scale
Model, then subsequent use of the mouse wheel to zoom in even further did not zoom in to the correct
location. Note that if either the Zoom Camera method or the Scale Model method was used for the entire
zoom operation, then the problem did not occur. Notice also that the Mouse Zoom Method in the
View>View Control menu has been renamed to Mouse Wheel/Right Mouse Button (if the Traditional
mouse scheme is used) or to just Mouse Wheel (if the Auto-Dynamic mouse scheme is used).

Hiding a contact body defined by a solid with faceted surfaces did not work correctly.

The Face Flood selection method did not work correctly for collapsed elements.
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MARC-13496
MARC-12886

Marc Reader
MARC-14825

MARC-14586

MARC-14083

MARC-13609

Nastran Reader

MARC-13853

Menu System
MARC-14807

MARC-13874
MARC-13599

MARC-13506

Other

MARC-14487
MARC-14217

MARC-13837

List of Fixed Defects in the 2020 Release

The Zoom Box option was not working when Dynamic Mouse Control is switched on.

Creating an st file in binary file format did not work (instead of a binary file, an ascii file was created).
Now the extension .stlb is used for binary files (the extensions .stla and .asc are used for ascii files).

The flag to exclude films on element edges (2-D) or faces (3-D) which are fully in contact (6th field of the
3rd data block of the FILMS option for table-driven input) was not imported. As a result, films were
always active, irrespective of the contact conditions.

The option to exclude fully damaged elements from the post file was not imported for the Gurson damage
model.

Upon importing a Meshed Rigid Contact Body with Control Type Position or Velocity, its Control Type
was set to Load.

The algorithm to automatically create names of boundary conditions has been improved in order to speed
up the import of data files with a large number of boundary conditions.

The section names in BDF files exported by Apex were not imported by Mentat and used as Geometric
Property names.

Mentat could terminate prematurely while recompiling the binary menu file (main.msb), if it has been
configured such that the dark theme is automatically enabled at startup (via the Save button in the Theme
> Settings box in the Mode > Settings menu). The created binary menu file was empty and invalid in that
case.

If a new directory is created via the file browser in Mentat, the name of this new directory was only partly
visible if the dark theme is used.

The Beam Section button in the Geometric Properties menu for beam elements did not work correctly.

In the CONVERT menu, it was suggested that a surface could be converted to a solid face, instead of a
sheet body, and a curve to a solid edge, instead of a wire body.

When the first element in a model is collapsed quad element, exporting the model to a bdf file failed.

An empty line embedded within a node or element card in I-deas universal file would cause an incomplete
translation of that entry.

Several API's have been added to the Python interface, allowing the user to access data of the following
entities: RBE2, RBE3, RROD, BOLTS, Boundary Conditions and Initial Conditions. Please refer to the
Python Manual for more information.
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MARC-13721
MARC-13716

MARC-13655
MARC-13575

MARC-13518

Pre Processing

MARC-14467

MARC-10989

Plane strain, plane stress and axisymetric Geometric Properties were exported as PSHELL, instead of

PLPLANE and PSHLN2.

The axisymmetric element type 89 was exported as CBEND and PSHELL, instead of CAXISYM and
PAXISYM.

The truss element type 9 was exported as the CBAR Nastran element, instead of the CROD element.

If a model with default job parameters is saved in an older style than the default (2019.1), then Mentat
would crash. The workaround was to manually set at least one job parameter.

On Windows, any of the command line options containing a directory name (i.e. -bp, -hp, -ml, -mp, -
path and -pl), did not function correctly if the directory name contains one or more spaces.

Switching off the Linear Elastic Analysis option could cause some other job options to be changed, more
precisely the option Nonlinear Procedure:Small Strain/Large Strain in the Analysis Options menu, and the
options Large Rotation, Large Strain:Automatic/Updated Lagrange/Total Lagrange and Plasticity
Procedure:Additive Decomposition/Multiplicative Decomposition in the Advanced Analysis Options
menu.

If a boundary condition or initial condition is applied to a surface and the surface has one or more
trimming curve loops, such that part of the surface is trimmed off (for example, a plate with a hole), and
if the boundary condition or initial condition is displayed on the surface (i.e. the Draw On Mesh options
in Boundary Conditions ->Plot Settings and Initial Conditions -> Plot Settings are not switched on; this
is the default) then the arrows of the boundary condition or initial condition could be drawn outside the
surface definition (i.e. outside the region enclosed by the trimming curve loop(s)). This was purely a
rendering issue and did not affect the mesh entities to which the boundary condition or initial condition
is applied in the analysis. The latter can be checked by switching on the Draw On Mesh options.
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List of Build and Supported Platforms - Marc 2020 Release

Marc Platforms

Linux (64 bit) ~ Red Hat RHEL 7.3/7.5 Intel EM64T or AMD Opteron  Intel XE 19.04! Intel MPI 2019 Update 4

SUSE 12SP1/SP2 Intel EM64T or AMD Opteron  Intel XE 19.04! Intel MPI 2019 Update 4
Windows (64- Windows 10 Intel EM64T or AMD Opteron  Intel XE 19.04! Intel MPI 2019 Update 4%
bit) Windows Server 2016

1 When using user subroutines, Intel Fortran XE 19.04 must be installed. When using user subroutines on Windows, Microsoft Visual Studio 2017 must
also be installed.

2 Supports also Microsoft MPI program version 9.0.

Mentat Platforms

Vendor 0S Hardware
Linux (64-bit) Red Hat RHEL 7.3/7.5 Intel EM64T or AMD Opteron
SUSE 12SP1/SP2
Windows (64-bit) Windows 10 Intel EM64T or AMD Opteron
Windows Server 2016
All platforms support Python 3.6.

Mentat Graphics Card Support

The following graphics boards have been certified to work with the Mentat 2019 release:

Graphics Board Graphics Driver Version

AMD FirePro V4800 (FireGL V) 15.201.2401.0
AMD FirePro W4190M 21.19.142.32768
AMD Radeon Pro WX 4130 21.19.384.3
AMD Radeon Pro WX 4130 21.19.384.3
AMD Radeon Pro WX 4150 21.19.384.3
AMD Radeon Pro WX 7100 21.19.384.3
AMD Radeon Pro WX4150 16.40.3801.1002
AMD Radeon WX2100 22.19.640.2
AMD Radeon WX2100 22.19.640.2
AMD Radeon WX3100 22.19.640.2

AMD Radeon WX3100 22.19.640.2
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Graphics Board Graphics Driver Version

AMD Radeon Pro WX 3100
AMD Radeon Pro WX 3200
AMD Radeon WX4100
AMD Radeon WX4100
AMD Radeon WX4100
AMD Radeon WX5100
AMD Radeon WX7100
AMD Radeon WX9100
AMD Radeon WX9100
AMD Radon Pro WX3100
AMD Radon Pro WX3200
AMD Radon Pro WX4100
AMD Radon Pro WX5100
AMD Radon Pro WX7100
AMD Radon Pro WX8200
AMD Radon Pro WX9100
Nvidia Quadro M1200
Nvidia Quadro M1200
Nvidia Quadro M1200
Nvidia Quadro M2200
Nvidia Quadro M2200
Nvidia Quadro P1000
Nvidia Quadro P2000
Nvidia Quadro P2000
Nvidia Quadro P3000
Nvidia Quadro P3200
Nvidia Quadro P4000
Nvidia Quadro P4000
Nvidia Quadro P4000
Nvidia Quadro P5000
Nvidia Quadro P5000
Nvidia Quadro P5000
Nvidia Quadro P600

23.20.787.768
19.Q2
17.10.1730.1004
22.19.640.2
22.19.640.2
17.10.1730.1004
17.10.1730.1004
22.19.640.2
22.19.693.256
26.20.13028.13
26.20.13028.13
26.20.13028.13
26.20.13028.13
26.20.13028.13
26.20.13028.13
26.20.13028.13
21.21.13.7586
377.43

377.43
21.21.13.7586
377.43

377.11

377.11
23.21.13.8908
21.21.13.7586
23.21.13.8908
21.21.13.7586
377.11

385.69
21.21.13.7586
377.43

377.11

377.11
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Graphics Board Graphics Driver Version

Nvidia Quadro P600 23.21.13.8908
Nvidia Quadro P6000 377.11

Nvidia Quadro P620 23.21.13.9077
Nvidia Quadro RTX 5000 25.21.14.1917
Nvidia Quadro RTX 6000 25.21.14.1917
Nvidia Quadro RTX 4000 25.21.14.1917
Nvidia Quadro 2200 26.21.14.3064
Nvidia Quadro T1000 25.21.14.2591
Nvidia Quadro RTX3000 25.21.14.2591
Nvidia Quadro RTX5000 25.21.14.2591

Peripheral Devices

3DCONNEXION’s SpacePilot PRO, SpaceMouse PRO and SpaceNavigator products, have been tested with Mentat. For
Linux based systems, see the Marc and Mentat: Installation and Operations Guide for additional information.
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Security Notes

The 2020 Beta release requires the FlexLM 11.16 (Helium) server version and stores the license manager (Imgrd) by default
in the directory C: \Program Files\MSC.Software\MSC Licensing\Helium\1lmgrd for Microsoft Windows and
for Linux platforms it is /msc/MSC. Software/MSC Licensing/Helium/lmgrd. The defaultlocation for the license
file is MSC Licensing/Helium.

The capabilities that require a license are given below with feature names as required in the license file.

1. MARC license required to run one single processor job or one instance of a
multiple processor (parallel) job.
2.  MARC_Parallel license required per processor in a parallel run (either DDM, or parallel
element assembly and stress recovery, or parallel CASI).
3.  MARC_Mesh2D license required for each run requiring automatic 2-D remeshing feature in
Marc.
4. MARC_Mesh3D license required for each run requiring automatic 3-D remeshing feature in
Marec.
MARC_ShapeMemory license required for each run using shape memory model.
MARC_MetalCutting license required for each run modeling metal cutting operation.
MARC _Electrical license required for Joule-Mechanical, Coupled Electrostatic- Structural,
and Piezoelectricity.
8. MARC_GPU license required to use the GPGPU solver capability.
9. MARC_CASI license required to use the CASI iterative solver.
10. MARC_Hexmesh license required for each instance of Hexahedral mesher.
11. MARC_MatFit license required for advanced material data fitting.
12. MARC_PhaseTrans license required for MICROSTRUCTURE phase transformation model.
13.  MARC_CoSim_Adaptor license required to run a co-simulation analysis with MSC CoSim.
14.  Mentat license required for each instance of Mentat.
15.  Mentat_Parasolid_CAD license required for each instance of Parasolid when working

(import/export/meshing) with Parasolid based models. This license does
NOT allow the creation of solid geometry or the modification of solid
geometry through Booloean operations, blending, and/or feature
recognition and removal.

16.  Mentat_Parasolid_Modeling license required for each instance of Parasolid when working
(import/export/creation/modification/ meshing) with Parasolid based
models.

17.  Mentac_ITI Access license required for each instance of, or exporting a file using the DXF,
IGES, or VDAES translators.

18. Mentat_ CMOLD license required for each instance of CMOLD when working

(import/export) with CMOLD based models.



Marc and Mentat Release Guide 2020

19.

20.

21.

22.

23.

24.

25.

26.

Mentat_Geometry_Translators
Mentat_ CATIAV4_Access
Mentat_ CATIAV5_Access
Mentat_Creo_Access
Mentat_Inventor_Access
Mentat_JT_Access

Mentat NX_Access

Mentat_SolidWorks_Access

21
Security Notes

license required for import of Parasolid, IGES, IDEAS, ACIS, STER, STL

to Parasolid Geometry with cleanup of model.

license required for import of CATIAV4 model to Parasolid Geometry with
cleanup of model.

license required for import of CATIAV5 model to Parasolid Geometry with
cleanup of model.

license required for import of Creo and Pro/E model to Parasolid Geometry
with cleanup of model.

license required for import of Inventor model to Parasolid Geometry with
cleanup of model.

license required for import of JT model to Parasolid Geometry with
cleanup of model.

license required for import of NX model to Parasolid Geometry with
cleanup of model.

license required for import of SolidWorks model to Parasolid Geometry
with cleanup of model.
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